Ask Your Question
0

Data Feeds missing fields

asked 2015-07-16 11:21:17 -0500

Hello, I use phRETS to connect to two different MLS feeds and one of them is sending back data that is missing fields or is totally out of sync.

edit retag flag offensive close merge delete

Comments

We need more information to help you in this: What sites, login URLs are you using? Login name you are using to access RETS. What specific data is missing or out of sync? Resource, Class, specific data that is missing?

bwolven gravatar imagebwolven ( 2015-07-16 11:44:35 -0500 )edit

Ok, here are the two feeds

http://wcmnmls-sasi.rets.paragonrels.com/rets/fnisrets.aspx/WCMNMLS/login?rets-version=rets/1.7.2 Login: KruegerRRETS

http://rasm-sasi.rets.paragonrels.com/rets/fnisrets.aspx/RASM/login?rets-version=rets/1.7.2 Login: PCDudes

The Commercial feed is missing the ListingID and all of the data is out of sync.

The Residential Open House feed is also missing the ListingId and is out of sync.

PC Dudes gravatar imagePC Dudes ( 2015-07-16 11:58:28 -0500 )edit

Can you try WCMNMLS now and see if it is working correctly?

bwolven gravatar imagebwolven ( 2015-07-16 15:36:01 -0500 )edit

WCMNMLS is working.

PC Dudes gravatar imagePC Dudes ( 2015-07-16 15:43:49 -0500 )edit

Can you try RASM now and see if that is working?

bwolven gravatar imagebwolven ( 2015-07-16 16:45:58 -0500 )edit

No, it is not working correctly.

PC Dudes gravatar imagePC Dudes ( 2015-07-16 16:55:44 -0500 )edit

Can you give me a more information on what issue you are having with RASM and the specific resource, class and fields you are having problems with?

bwolven gravatar imagebwolven ( 2015-07-17 08:06:24 -0500 )edit

How do I use the Select parameter? I have not seen any references to it in the documentation.

PC Dudes gravatar imagePC Dudes ( 2015-07-17 10:17:08 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-17 09:33:22 -0500

updated 2015-07-17 09:33:52 -0500

I checked the RASM RETS feed for these: Resource: OpenHouse, Class: SF_1 Resource: Property, Class: CI_5 The only thing that I see is that the columns are not being returned in an order consistent with the other classes. But the L_ListingID field is in the data being returned. You should never assume the order. You should always use the COLUMNS tag returned to determine the position of the data. The order can change with the addition or removal of fields or business or security rules. Or you can use the Select parameter to specify the order you desire.

edit flag offensive delete link more

Comments

1

Want to reiterate a key point in Bruce's message:

You should never assume the order. You should always use the COLUMNS tag returned to determine the position of the data.

Always check the data, to ensure you're using the columns correctly.

vendorsupport gravatar imagevendorsupport ( 2015-07-17 15:03:07 -0500 )edit
0

answered 2015-07-17 10:43:40 -0500

You would just put the comma separated list of field names in the order you want:

Select=L_ListingID,L_Class,L_Type_,L_Area,L_SystemPrice

This allows you to specify the order and also to exclude fields you don't care about.

edit flag offensive delete link more

Comments

Ok, thank you for your help Bruce.

PC Dudes gravatar imagePC Dudes ( 2015-07-17 10:50:03 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-07-16 11:21:17 -0500

Seen: 477 times

Last updated: Jul 16 '15