Ask Your Question
0

RANW ID=*&Type=METADATA-SYSTEM Only Returns Metadata-System

asked 2017-02-13 14:39:33 -0500

Account Name iCheck URL http://ranwmls.rets.paragonrels.com/r...

Sending ID=*&Type=METADATA-SYSTEM should return ALL Metadata, and does on all other BNFS accounts.

On RANW the RETS server only returns METADTA-SYSTEM

Here's an example

SENT POST /rets/fnisrets.aspx/RANWMLS/getmetadata HTTP/1.1 Authorization: Digest username="iCheck", realm="RANWMLS", nonce="2017-02-13T16:02:55", uri="/rets/fnisrets.aspx/RANWMLS/getmetadata", cnonce="MDQ0NTU2", nc=00000002, qop="auth", response="740e9dd752e08c94492ca7413d88fa74", opaque="""" User-Agent: iCheck/2.5 Host: ranwmls.rets.paragonrels.com Accept: / Cookie: RETS-Session-ID=-eb8b940b-81f7-4fee-b06e-6b1b01ba7934- RETS-Version: RETS/1.7.2 RETS-UA-Authorization: Digest 2b488908a42261ba123758d97158a68c Content-Length: 40 Content-Type: application/x-www-form-urlencoded

Format=COMPACT&ID=*&Type=METADATA-SYSTEM <<<received header="" http="" 1.1="" 200="" ok="" cache-control:="" private="" transfer-encoding:="" chunked="" content-type:="" text="" xml;="" charset="utf-8" expires:="" mon,="" 01="" jan="" 0001="" 00:00:00="" gmt="" rets-server:="" rets-paragon="" 1.0="" rets-version:="" rets="" 1.7.2="" content-id:="" metadata-system="" x-server:="" a51="" date:="" mon,="" 13="" feb="" 2017="" 15:52:55="" gmt="" vary:="" accept-encoding<="" p="">

<rets replycode="0" replytext="SUCCESS" &gt;="" <metadata-system="" version="17.2.13074" date="2017-02-09T01:54:16.5Z"> <system systemid="RANWMLS" systemdescription="REALTORS Assoc.of NE WI MLS" timezoneoffset="Z"/> <comments></comments> </metadata-system>

* OTHER METADATA SHOULD BE HERE such as… <metadata-class version…="" {snip}="" <="" metadata-class=""> <metadata-editmask version…="" {snip}="" <="" metadata-editmask="" &gt;="" <metadata-foreign_keys="" version…="" {snip}="" <="" metadata-foreign_keys="" &gt;="" <metadata-lookup="" version…="" {snip}="" <="" metadata-lookup="" &gt;="" <metadata-lookup_type="" version…="" {snip}="" <="" metadata-lookup_type="" &gt;="" <metadata-object="" version…="" {snip}="" <="" metadata-object="" &gt;="" <metadata-system="" version…="" {snip}="" <="" metadata-system="" &gt;="" <metadata-table="" version…="" {snip}="" <="" metadata-table="" &gt;="" etc…<="" p="">

</rets>

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-02-13 16:54:35 -0500

Thank you, it is fixed!

edit flag offensive delete link more
0

answered 2017-02-13 15:20:03 -0500

Tony, this should be working now. Let me know if your issues are fixed.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-13 14:39:33 -0500

Seen: 1,064 times

Last updated: Feb 13 '17