Ask Your Question
0

CREN url changes, no data access

asked 2018-11-14 19:19:34 -0600

Thin Air gravatar image

Greetings! We have two sets of credentials passed in, and they stopped working a few days ago, due to a url change and rets update to 1.7.2

Below are the old settings (we have two functions, hence the two formats), followed by our attempt to implement the new url's.

OLD SETTINGS: [rets_srv] ver = RETS/1.5 url = http://cren.rets.fnismls.com/rets/fni... user = winner pass = XXXXXXXXXX

And since we have a second level of permissions for the user data:

$retsLogin = array( 'ver' => 'RETS/1.5', 'url' => 'http://cren.rets.fnismls.com/rets/fnisrets.aspx/CREN/login', 'user' => 'winner', 'pass' => 'XXXXXXX', 'user_agent' => 'ThinAir', 'ua_pass' => 'XXXXXXX',

NEW SETTINGS: [rets_srv] ver = RETS/1.7.2 url = https://cren-rets.paragonrels.com/ret... user = winner pass = XXXXXXXXX

$retsLogin = array( 'ver' => 'RETS/1.7.2', 'url' => 'https://cren-rets.paragonrels.com/rets/fnisrets.aspx/CREN/login', 'user' => 'winner', 'pass' => 'XXXXXXXXX', 'user_agent' => 'ThinAir', 'ua_pass' => 'XXXXXXXXX,

Can you suggest the correct and updated syntax? Should the rets version get passed in via the url now? https://cren-rets.paragonrels.com/ret...

Thank you for your assistance!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-11-15 08:44:13 -0600

Sorry about the URL issues.
The fnismls.com URL has been legacy for many years now and we've been trying to get people to stop using it.
I take it you are using PHRETS?
With HTTPS we require Basic authentication and HTTP we require Digest.
That could be where you are having issues.
You set it using $config->setHttpAuthenticationMethod('basic');
We like vendors to use HTTPS where possible.
But if that doesn't work, change the new URL to HTTP.

edit flag offensive delete link more
0

answered 2018-11-15 09:07:40 -0600

Thin Air gravatar image

Thanks! We've successfully reconnected by reverting back to http: for now. We'll continue testing once the dust settles, and work toward using the https: connection.

We've successfully run our listing update scripts, but our CDN Image update script appears to be not updating fully. We'll continue testing, and reach out again if needed.

For others viewing this message, here is the current working configuration:

[rets_srv] ver = RETS/1.7.2 url = http://cren-rets.paragonrels.com/rets... user = winner pass = xxxxxxxx

$retsLogin = array( 'ver' => 'RETS/1.7.2', 'url' => 'http://cren-rets.paragonrels.com/rets/fnisrets.aspx/CREN/login', 'user' => 'winner', 'pass' => 'xxxxxxxxx', 'user_agent' => 'ThinAir', 'ua_pass' => 'xxxxxxx,

edit flag offensive delete link more

Comments

Any stored Image URLs you have are probably not valid since the environment change.
They would be pointing to the old environment which no longer has the images.

bwolven gravatar imagebwolven ( 2018-11-15 09:14:52 -0600 )edit

Were you able to get your CDN image updates working again?

bwolven gravatar imagebwolven ( 2018-11-15 15:22:54 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-14 19:19:34 -0600

Seen: 22 times

Last updated: Nov 15