Ask Your Question
0

One of our vendors sent us this issue. Can anyone help?

asked 2015-07-02 09:47:47 -0500

phall gravatar image

updated 2015-07-02 12:36:40 -0500

mdean gravatar image

Hi,

We were given access to CBTREG recently. When we perform a search on Property, we are getting an error message. Our login is coldwellbankertreg

The query we used is http://cwbr.rets.fnismls.com/rets/fnisrets.aspx/CWBR/Search?rets-version=rets/1.5&QueryType=DMQL2&StandardNames=0&Count=0&Format=COMPACT-DECODED&Limit=NONE&SearchType=Property&Class=RE_1&Query=(L_ListOffice1=344)

The error message is <rets-status replytext="FieldDescription [L_IdxInclude] not in table. Error in the application." replycode="20200"/>

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-02 12:36:08 -0500

mdean gravatar image

The RETS profile for this user has the IDX Rules option enabled for the profile. This setting automatically adds criteria to the query to limit the results to those that comply with IDX rules (i.e., are not excluded at the listing level nor has the broker opted out of participating in IDX).

The configuration of this system is set up in a way that it is not using the built-in IDX field, but a custom lookup field defined by the MLS.

To fix this, the MLS has two options:

  1. Convert the custom IDX field to the standard Paragon IDX field (this will enable the L_IdxInclude field in RETS)
  2. Change the profile to not enforce IDX rules, but instead add (LM_char10_39=Y) to the DMQL filter. Additionally, will need to add a filter to exclude offices that have opted out of IDX.

Option 1 would be preferred, since it will also take broker opt-out into account along with the individual listing opt-out settings. Option 2 can be done, but requires upkeep as brokers can opt in and out of IDX.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2015-07-02 09:47:47 -0500

Seen: 622 times

Last updated: Jul 02 '15