Ask Your Question
0

image urls inconsistent - causing issues

asked 2020-01-21 15:01:05 -0500

Hello,

Some image urls in media resource are coming in without 'http:', and others are coming in right with full http://.... Can you make all the links consistent to have 'http:' for all images.

Rets Url: http://mimls.rets.paragonrels.com/ret... AccName: MCav*ad

Ex 1: MLS# 20005189 Link: //cdnparap80.paragonrels.com/ParagonImages/Property/P8/MIMLS/20005189/0/0/0/540a1e63118063acf4258c8c9a76fe14/97/9de12844e195856685029228a188b96c/20005189.JPG

Ex 2: MLS# 20366275 Link: http://cdnparap60.paragonrels.com/Par...

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-22 11:54:01 -0500

Sorry for the confusion.
All the Image URLs with domain "cdnpara*.paragonrels.com" should be returned as protocol relative.
Protocol Relative: "//cdnparap80.paragonrels.com/..."
We identify URLs that the vendor can use either "HTTP:" or "HTTPS:" with this way.
With some boards, we store URLs to their external images directly which may or may not support both.
I would suggest that you add which protocol you desire to use when you pull the data for the relative ones.

edit flag offensive delete link more

Comments

Great, Thank you! If the links are consistent, with or without protocol in an MLS, this would be good. We somehow ended up getting other MLS image records when we queried for MIMLS. Those other MLS records had protocol in links I see that all the links are now without any protocol in MIMLS. We will append protocol for each link. Thanks again!

David gravatar imageDavid ( 2020-01-22 12:41:20 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-21 15:01:05 -0500

Seen: 58 times

Last updated: Jan 22