Ask Your Question

Revision history [back]

Image issues in SDMLS for images from CRMLS

Hello,

RETS URL: https://spn-rets.paragonrels.com/rets/fnisrets.aspx/SPN/login?rets-version=rets/1.7.2 Username: 500288

We are experiencing an intermittent issue where when we request images, we receive a 403 error from cloudfront.

Here is an example error:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<HTML><HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">

<TITLE>ERROR: The request could not be satisfied</TITLE>

</HEAD><BODY>

<H1>403 ERROR</H1>

<H2>The request could not be satisfied.</H2>

<HR noshade size="1px">

Request blocked.

<BR clear="all">

<HR noshade size="1px">

<PRE>

Generated by cloudfront (CloudFront)

Request ID: aDOcEBXfSQUn1f_5yNzCIcySSaEcXj9Jx0ZnLGcvW7vzRy6WO4WEwQ==

</PRE>

<ADDRESS>

</ADDRESS>

</BODY></HTML>

Here is an example photo we were unable to pull on the initial request due to the cloudfront 403 issue performed with the SDMLS credentials above:

Unable to get image id 300968758 at path /Property/Photo: http://media.crmls.org/mediaz/6C129487-D4F5-4CDB-8AFA-AEC2B0D34616.jpg

We are actually experiencing this issue on 4 different data feeds from 4 different data vendors that all receive images with media URLs from CRMLS, I have a separate ticket open with CRMLS where they instructed me to reach out to each of the individual data providers for these feeds to get this issue corrected for each feed.

Please let me know if you need any additional information.