Ask Your Question

Revision history [back]

Connection issue

Hello,

I keep having a connection issue trying to connect throught PHRets

[2020-10-09 16:42:55] PHRETS.DEBUG: Loading Monolog\Logger logger [] []
[2020-10-09 16:42:55] PHRETS.DEBUG: Sending HTTP Request for http://maxebrdi-rets.paragonrels.com/rets/fnisrets.aspx/MAXEBRDI/login?rets-version=rets/1.7.2 (Login) {"auth":["**USER**","**PASS**","basic"],"headers":{"User-Agent":"PHRETS/2.6.1","RETS-Version":"RETS/1.7.2","Accept-Encoding":"gzip","Accept":"*/*"},"curl":{"10031":"/tmp/phretsRRoUkF"}} []
[2020-10-09 16:42:55] PHRETS.DEBUG: ClientException: 401: Client error: `GET http://maxebrdi-rets.paragonrels.com/rets/fnisrets.aspx/MAXEBRDI/login?rets-version=rets/1.7.2` resulted in a `401 Unauthorized` response [] []
http/promises/src/Promise.php(203): GuzzleHttp\\Middleware::GuzzleHttp\\{closure}(Object(GuzzleHttp\\Psr7\\Response))\n#2 /var/app/current/vendor/guzzlehttp/promises/src/Promise.php(156): GuzzleHttp\\Promise\\Promise::callHandler(1, Object(GuzzleHttp\\Psr7\\Response), Array)\n#3 /var/app/current/vendor/guzzlehttp/promises/src/TaskQueue.php(47): GuzzleHttp\\Promise\\Promise::GuzzleHttp\\Promise\\{closure}()\n#4 /var/app/current/vendor/guzzlehttp/promises/src/Promise.php(246): GuzzleHttp\\Promise\\TaskQueue->run(true)\n#5  in /var/app/current/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php on line 113

When I try to connect using Retsmd.com I don't seem to have any issues so I know the username and password are correct.

What am I doing wrong? We have a dozen other Rets connections running using the same code base without any issues.

Thanks Eric