Ask Your Question

Great Plains Regional MLS: Data Vendor Update - URL for RETS Access

asked 2022-05-19 17:11:50 -0600

Feed Information: Classic RETS URL: Account Name: 967124

Hi @bwolven

The URL we are using is slightly different: The difference between the two is we have a dot between oabrmls and rets and you have a dash. Also, we are using http and not https We tried both the dash and dot and both worked, but when we updated the protocol to https, its not working for us. When we send this query:

we get back an HTTP status code of 401 with an "unauthorized" response from the server. We have tried removing theUser-Agents=RedfinRetsClient/1.0, and tried both digest and non-digest authentication, and no combination of these is working with the https protocol. https didnt work with basic or digest.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-05-20 08:39:34 -0600

updated 2022-05-20 08:40:53 -0600

Having the DASH makes a difference when using HTTPS,
I would advise always using the dash
The other requirement for HTTPS is that you use Basic authentication.
HTTP requires Digest.

edit flag offensive delete link more


@bwolven Yes, however when we tried that, with https, Basic authentication and the dash, it didn't work, we got a 401 Unauthorized error.

Redfin MLS Team gravatar imageRedfin MLS Team ( 2022-05-20 10:36:53 -0600 )edit

This is the exact query we are sending:

And this is the trimmed response:

2022-05-20 08:39:35,368 pool-12-thread-1 WARN HTTP status code does not indicate success: 401; response content (first 256 chars): <html xmlns=""> <head>

Redfin MLS Team gravatar imageRedfin MLS Team ( 2022-05-20 10:41:42 -0600 )edit

We were able to get this worked out. Thank you!

Redfin MLS Team gravatar imageRedfin MLS Team ( 2022-05-20 10:52:40 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2022-05-19 17:11:50 -0600

Seen: 73 times

Last updated: May 20