Ask Your Question
0

How do we upgrade

asked 2022-11-21 17:15:52 -0600

updated 2022-11-30 10:56:10 -0600

We have been told we need to upgrade to https - our login URL is http://maui.rets.paragonrels.com/rets...

We have also used https://retsmd.com/index.php to find new fields

How do we get an updated login - I just spoke with RAM Maui and they said we were still going to be getting data from maui.rets.paragonrels.com

edit retag flag offensive close merge delete

Comments

Change your URL to:

https://maui-rets.paragonrels.com/rets/fnisrets.aspx/MAUI/login?rets-version=rets/1.7.2

Change your authentication to use Basic instead of the current Digest.

You can test the URL in a browser to see if your login credentials are working.
Make sure that you include the rets-version parameter when you enter it in the browser.
Make sure you use the exact character case for your password.

bwolven gravatar imagebwolven ( 2022-11-21 17:20:44 -0600 )edit

When I add the https to the feed script it comes back with: Fatal error: Uncaught exception 'GuzzleHttp\Exception\ClientException' with message 'Client error: GET https://maui-rets.paragonrels.com/rets/fnisrets.aspx/MAUI/login?rets-version=rets/1.7.2 resulted in a 401 Unauthorized

But it works fine with http in the $config->setLoginUrl field

IGDTech gravatar imageIGDTech ( 2022-11-23 15:43:39 -0600 )edit

Did you change the Authorization to Basic?
$config->setHttpAuthenticationMethod('basic')

bwolven gravatar imagebwolven ( 2022-11-24 06:35:44 -0600 )edit

$config->setHttpAuthenticationMethod('basic')

I get: Fatal error: Uncaught exception 'GuzzleHttp\Exception\RequestException' with message 'cURL error 60: SSL: no alternative certificate subject name matches target host name 'maui.rets.paragonrels.com'

IGDTech gravatar imageIGDTech ( 2022-11-25 09:00:13 -0600 )edit

what happens if you attempt to add a -k into your request? If that doesn't work, could you give a bit more of the request you're currently using? (not displaying any username or passwords)

Sadie gravatar imageSadie ( 2022-11-25 11:00:39 -0600 )edit

The full error message:

Fatal error: Uncaught exception 'GuzzleHttp\Exception\RequestException' with message 'cURL error 60: SSL: no alternative certificate subject name matches target host name 'maui.rets.paragonrels.com' (see http://curl.haxx.se/libcurl/c/libcurl... in RAM/PHRETS/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:187 Stack trace: #0 RAM/PHRETS/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(150): GuzzleHttp\Handler\CurlFactory::createRejection(Object(GuzzleHttp\Handler\EasyHandle), Array) #1 RAM/PHRETS/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(103): GuzzleHttp\Handler\CurlFactory::finishError(Object(GuzzleHttp\Handler\CurlHandler), Object(GuzzleHttp\Handler\EasyHandle), Object(GuzzleHttp\Handler\CurlFactory)) #2 RAM/PHRETS/vendor/guzzlehttp/guzzle/src/Handler/CurlHandler.php(43): GuzzleHttp\Handler\CurlFactory::finish(Object(GuzzleHttp\Handler\CurlHandler), Obj in RAM/PHRETS/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 187

IGDTech gravatar imageIGDTech ( 2022-11-25 17:36:03 -0600 )edit

From the error message above, it looks like you didn't change your URL domain.
The domain name needs to be "maui-rets.paragonrels.com" to match certificate.
You should use that regardless of whether you are using HTTP or HTTPS.

bwolven gravatar imagebwolven ( 2022-11-26 04:35:10 -0600 )edit

I changed the domain to: maui-rets.paragonrels.com

I now get: Fatal error: Uncaught exception 'GuzzleHttp\Exception\ClientException' with message 'Client error: GET https://maui-rets.paragonrels.com/rets/fnisrets.aspx/MAUI/login?rets-version=rets/1.7.2 resulted in a 401 Unauthorized response: <html xml="" '="" in="" ram="" phrets="" vendor="" guzzlehttp="" guzzle="" src="" exception="" requestexception.php:111="" stack="" trace:="" #0="" ram="" phrets="" vendor="" guzzlehttp="" guzzle="" src="" middleware.php(65):="" guzzlehttp\exception\requestexception::create(object(guzzlehttp\psr7\request),="" object(guzzlehttp\psr7\response))="" #1="" ram="" phrets="" vendor="" guzzlehttp="" promises="" src="" promise.php(203):="" guzzlehttp\middleware::guzzlehttp{closure}(object(guzzlehttp\psr7\response))="" #2="" ram="" phrets="" vendor="" guzzlehttp="" promises="" src="" promise.php(156):="" guzzlehttp\promise\promise::callhandler(1,="" object(guzzlehttp\psr7\r="" in="" ram="" phrets="" vendor="" guzzlehttp="" guzzle="" src="" exception="" requestexception.php="" on="" line="" 111<="" p="">

IGDTech gravatar imageIGDTech ( 2022-11-26 09:35:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-11-26 16:11:18 -0600

And you did set it to basic authentication?
$config->setHttpAuthenticationMethod('basic')
If that doesn't work, try the login URL you are using in a browser and login when prompted to verify that your account works.
If the HTTPS URL doesn't work in the browser but changing the URL to HTTP does
then most likely the character case of the password you are using is incorrect.
It must be the exact case. Digest is a little more relaxed.

edit flag offensive delete link more

Comments

Well that appears to be the issue - the had the 'basic' option set in the wrong place I set $config->setHttpAuthenticationMethod('basic') It ran through without error.

IGDTech gravatar imageIGDTech ( 2022-11-26 18:23:55 -0600 )edit

So are you working now using HTTPS?
This is another useful PHRETS option to use POST instead of GET:
$config->setOption('use_post_method', true);

bwolven gravatar imagebwolven ( 2022-11-28 09:00:31 -0600 )edit

Yes it is now updating with the HTTPS

Thank you for you help.

IGDTech gravatar imageIGDTech ( 2022-11-28 11:51:06 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2022-11-21 17:15:52 -0600

Seen: 51 times

Last updated: Nov 23