Ask Your Question
0

Issue with converting from http to https

asked 2022-12-02 15:38:56 -0600

updated 2022-12-07 16:24:46 -0600

Good afternoon,

I am trying to convert to the secure URL format, but am getting a credentials invalid error once switching to https:

For Mid Hudson Multiple Listing Service and Great Plains REALTORS MLS:

Example = Mid Hudson Multiple Listing Service if i use the new URL "https://midh-rets.paragonrels.com/rets/fnisrets.aspx/midh/login" with BASIC authorization set in Postman, I get the following error:

<fieldset>

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.

Our credentials are as follows:

Mid Hudson Multiple Listing Service -Login URL: http://midh.rets.paragonrels.com/rets... -Login ID: 9112

Great Plains REALTORS MLS -Login URL: http://oabrmls.rets.paragonrels.com/r... -Login ID: 967547

edit retag flag offensive close merge delete

Comments

Two things you need to check right off the bat.
Domain should always have the dash and not dot for example: "midh-rets.paragonrels.com"
Second try the login URL in a browser, make sure to include the "?rets-version=rets/1.8" in the login URL.

https://midh-rets.paragonrels.com/rets/fnisrets.aspx/midh/login?rets-version=rets/1.8

If HTTP works with the URL above, but HTTPS doesn't, it is probably incorrect char case in password value.
If both work in the browser, make sure you are setting you app to use Basic authentication when using HTTPS.

bwolven gravatar imagebwolven ( 2022-12-02 18:40:29 -0600 )edit

Hello again, So I was able to get both http and https version to work in browser. However in Postman app, I am still getting the same error. I am specifying the app to use Basic authorization, but still getting a credentials invalid error.

djn1990 gravatar imagedjn1990 ( 2022-12-02 22:01:24 -0600 )edit

I was able to do it in postman.
You need to set authorization to basic for each request.
Call login first to establish the session, then send other requests, then logout.

bwolven gravatar imagebwolven ( 2022-12-03 07:29:51 -0600 )edit

Please see updated case notes and advise. I believe I am setting things as you described, but am not able to get to even login in using https URL.

djn1990 gravatar imagedjn1990 ( 2022-12-05 11:10:39 -0600 )edit

Your password is incorrect.
Try upper case and then change it since you posted on a public site.

bwolven gravatar imagebwolven ( 2022-12-06 08:56:26 -0600 )edit

Were you able to get this working?

bwolven gravatar imagebwolven ( 2022-12-06 11:19:27 -0600 )edit

Unfortunately upper-case on psw did not work. I will have our accounts person update our credentials. Perhaps that could resolve this?

djn1990 gravatar imagedjn1990 ( 2022-12-06 12:32:55 -0600 )edit

Make sure you have the dash domain name too "midh-rets.paragonrels.com".

bwolven gravatar imagebwolven ( 2022-12-06 13:24:17 -0600 )edit

Yes, this is the exact name we are using: https://midh-rets.paragonrels.com/ret...

djn1990 gravatar imagedjn1990 ( 2022-12-06 14:32:12 -0600 )edit

I'm still able to connect to midh using your credentials.
One thing I've found is that it may fail if cookies are present from a previous attempt.
When that happens, if I send again or clear cookies it works.

bwolven gravatar imagebwolven ( 2022-12-06 16:51:39 -0600 )edit

Hello, I have made sure to clear out cookies each time. After each attempted login/logout session.

djn1990 gravatar imagedjn1990 ( 2022-12-07 11:12:56 -0600 )edit

If I use the case you originally sent, I get the same Basic header you showed in your example.
Here's what I show in the console when I change the case to the proper one:
Authorization: Basic **
User-Agent: PostmanRuntime/7.29.2
Is that the same Authorization that your console shows when you send the request?
That one worked for me.

bwolven gravatar imagebwolven ( 2022-12-07 11:55:34 -0600 )edit

You need to look at the "console window" in Postman to see what value was actually sent.
To open console it is on the status bar in mine.

bwolven gravatar imagebwolven ( 2022-12-07 12:18:11 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-12-07 12:33:52 -0600

updated 2022-12-07 12:43:32 -0600

Okay, we have established connection for https://midh-rets.paragonrels.com/rets...

edit flag offensive delete link more

Comments

Could you please check new URL config for Great Plains REALTORS MLS -Login URL: http://oabrmls.rets.paragonrels.com/r... -Login ID: 967547

I am (1) using basic Auth, (2) have capitalized the letters in our psw, and (3) the URL is as follows: https://oabrmls-rets.paragonrels.com/...

Headers are: Authorization : Basic ** User-Agent. : PostmanRuntime/7.29.2

Still getting authorization error for this one.

djn1990 gravatar imagedjn1990 ( 2022-12-07 12:50:29 -0600 )edit

Than you, this works now too. Thank you for all you assistance, it has taught me a lot. Very much appreciate your time and patience on this. Have a great day.

djn1990 gravatar imagedjn1990 ( 2022-12-07 13:57:47 -0600 )edit

Please have your account manager change passwords for both sites now though.

bwolven gravatar imagebwolven ( 2022-12-07 13:59:50 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2022-12-02 15:38:56 -0600

Seen: 80 times

Last updated: Dec 07 '22