Ask Your Question
0

miscellaneous server error code after login call succeeds

asked 2023-01-25 12:49:55 -0600

updated 2023-01-26 08:42:18 -0600

We have had this issue since December & have been working with Richard Ford at MAAR & the SM.

Please know that the login call we make succeeds. Here’s the response:

<rets replycode="0" replytext="Login Request"> <rets-response>MemberName=Benson Juarez User=V000REDATALAB,1,30,18201 Broker=826,826 MetadataVersion=22.12.18152 MetadataTimestamp=2022-12-12T14:32:03.5Z MinMetadataTimestamp=2022-12-12T14:32:03.5Z TimeoutSeconds=5400 GetMetadata=/rets/fnisrets.aspx/MAAR/getmetadata GetObject=/rets/fnisrets.aspx/MAAR/getobject Login=http://maar.rets.paragonrels.com/rets/fnisrets.aspx/MAAR/login Logout=/rets/fnisrets.aspx/MAAR/logout Search=/rets/fnisrets.aspx/MAAR/search </rets-response> </rets>

But, when our Dev team makes this call:

http://maar.rets.paragonrels.com/rets...

They get

<rets replycode="20036" replytext="miscellaneous server error."></rets>

Please could you help resolve this?

edit retag flag offensive close merge delete

Comments

When I look in the logs, I see requests from User-Agent "RETSConnector/1.0" that are successful.
I also see some logins from 2023-01-09 11:22:29 CST that have User-Agent "RE Data Lab Inc./1.0"
Are these the ones that are failing for you?
If so, what client or client library are you using for your "RE Data Lab Inc./1.0" pulls?

bwolven gravatar imagebwolven ( 2023-01-25 14:21:25 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2023-01-25 14:49:44 -0600

updated 2023-01-25 15:28:18 -0600

If you are doing a roll your own requests make sure you are returning the RETS-Session-ID cookie returned by the login request when calling any other transactions such as search.
When you are finished with your set of transactions, make sure to call logout.

Another thing is that you need to pass in the rets-version header with each request.
You can do it by either passing it as a header, which is the preferred way.

Or you can add it as a URL parameter for each request like "&RETS-Version=RETS/1.8"
Also please change your domain to "maar-rets.paragonrels.com" which will aid when using HTTPS.

edit flag offensive delete link more

Comments

Were you able to get this working?

bwolven gravatar imagebwolven ( 2023-02-02 09:00:08 -0600 )edit

Hi @bwolven, Thank you for your help on this. I have just received an update from our Dev team stating they were able to figure out what was causing this issue with your suggestions/updates and they have applied a change on our end. This questions/issue can be resolved. Thank you again for taking the time to help us.

REDATALAB gravatar imageREDATALAB ( 2023-02-02 11:34:04 -0600 )edit

Great! Thanks for letting us know.

bwolven gravatar imagebwolven ( 2023-02-02 11:36:31 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2023-01-25 12:49:55 -0600

Seen: 30 times

Last updated: Jan 26