First time here? Check out the FAQ!

Can only login with Rets Connector

This is the login url: User name: dotsig

I am able to successfully login and pull data with RETS Connector, but phRETS and retsIQ both do not allow me to login

This is what I get from phRETS:

Array ( [type] => http [code] => 0 [text] => ) GetMetadataTypes() called but unable to find GetMetadata location. Failed login?

retsIQ throws errors about index -1 out of bounds (this is while doing a search after trying to connect).

The phRETS version just times out after trying to connect for a couple minutes.

Any one have any ideas on how to get around this?

Thanks in advance, Jared

jbarrus's avatar
asked 2017-02-14 10:18:23 -0500
edit flag offensive 0 remove flag close merge delete


Are you using the same HTTPS URL for all three environments?

bwolven's avatar bwolven (2017-02-15 09:53:39 -0500) edit

Yes, I am.

jbarrus's avatar jbarrus (2017-02-15 10:17:39 -0500) edit

With phRETS are you using basic authentication using HTTPS?

bwolven's avatar bwolven (2017-02-15 11:54:18 -0500) edit

phRETS handles the basic vs digest auth for me. I am going to post a separate comment with the code for how I connect since characters are limited here.

jbarrus's avatar jbarrus (2017-02-15 12:13:46 -0500) edit

$rets = new phRETS();

$rets->SetParam('catch_last_response', true); $rets->SetParam('compression_enabled', true); $rets->AddHeader("RETS-Version", "RETS/1.7.2"); $rets->AddHeader('Accept', '/'); $rets->AddHeader("User-Agent", $user_agent);

$connect = $rets->Connect($url, $user, $pass)

jbarrus's avatar jbarrus (2017-02-15 12:14:03 -0500) edit

I saw 4 successful logins come through with User Agent: "V1rtualAg3nt/1.7.2" without corresponding logouts. Is that the user agent you are using for phRETS?

bwolven's avatar bwolven (2017-02-15 13:59:57 -0500) edit

That is the user agent I am using in retsIQ, the java version of it. I have been using "RETS-Connector/1.2" the last couple days in phRETS (to see if something was going on with the user agent since I could only login with RETS Connector). Before that I was using "V1rtualAg3nt/172" in phRETS

jbarrus's avatar jbarrus (2017-02-15 14:05:34 -0500) edit

My preference is to use retsIQ, but it always throws this error: null String index out of range: -1
java.lang.StringIndexOutOfBoundsException: String index out of range: -1

That was for a call to getMetadata after connecting, it does the same thing for a call to Search

jbarrus's avatar jbarrus (2017-02-15 14:07:22 -0500) edit

What URL are you using to connect to retsIQ?

bwolven's avatar bwolven (2017-02-15 15:41:01 -0500) edit

I am using this url for retsIQ, phRETS, and RETS Connector:

jbarrus's avatar jbarrus (2017-02-15 15:45:22 -0500) edit

Does retsIQ support HTTPS?

bwolven's avatar bwolven (2017-02-15 16:03:15 -0500) edit

Yes it does, but maybe not with paragonrels for some reason? I integrated with this MLS this morning:

It works great on http, but gives the same error on https. I tried http on cren-rets last week, and it

jbarrus's avatar jbarrus (2017-02-15 16:20:17 -0500) edit

didn't work. But today it is. I greatly appreciate the time you've spent helping me. I'm curious why it won't work over https since I have other MLSs that work in retsIQ with https. I'm more confused about why phRETS won't work over https either.

jbarrus's avatar jbarrus (2017-02-15 16:21:54 -0500) edit

The main difference between HTTP and HTTPS connection with our servers is that HTTPS uses Basic authentication and HTTP requires Digest. But don't know if retsIQ has a setting for that or not?

bwolven's avatar bwolven (2017-02-15 16:45:44 -0500) edit

I don't see an option for that in retsIQ, but with phRETS I had tried the force_basic_authentication option this morning, and that oddly didn't resolve the problem. I have things running now on http. Thanks again.

jbarrus's avatar jbarrus (2017-02-15 16:52:02 -0500) edit
add a comment see more comments

1 Answer


User switched to HTTP URL and is working now.

bwolven's avatar
answered 2017-02-15 17:03:49 -0500
edit flag offensive 0 remove flag delete link


add a comment see more comments

Your Answer

Login/Signup to Answer