First time here? Check out the FAQ!

Slow Photo Imports

  • retag add tags

We are seeing some extremely slow photo imports across a number of our Paragon feeds.

For example, we are importing photos for a new feed, Tuolumne County MLS, and the photo import is taking almost 10 minutes to download photos for 5 listings. This is from our log:

2020-06-18 10:21:29 : Added Obect: 20190010 2020-06-18 10:21:29 : Added Obect: 20200368 2020-06-18 10:21:29 : Added Obect: 20200282 2020-06-18 10:21:29 : Added Obect: 20191982 2020-06-18 10:21:29 : Added Obect: 20200748

Those photo sets took until 10:29:10 to import.


User: RelianceNetwork

We are also seeing some significant slowing on our Illinois Alliance feed:



dhasler's avatar
asked 2020-06-18 12:43:44 -0500
edit flag offensive 0 remove flag close merge delete


We're also seeing a large number of photo errors in our RealSource feed:

URL: USER: MIRreliance

Example listings failing:

50014105 50014106 50014108 50014109 31393459 50014110 50014112

dhasler's avatar dhasler (2020-06-18 12:54:03 -0500) edit

How are you pulling them? GETOBJECT or Media resource?
And if GETOBJECT are you pulling Images or URL (Location=1)?

bwolven's avatar bwolven (2020-06-18 13:12:29 -0500) edit

Via a GETOBJECT request.

The Tuolumne feed is erroring when attempting to SetLocation=1, so we assumed they only provided the binary objects.

dhasler's avatar dhasler (2020-06-18 13:50:33 -0500) edit

What error are you getting with Location=1 on TCAR?
Here is an example of what I had returned for listing: 20190180

bwolven's avatar bwolven (2020-06-18 14:07:24 -0500) edit

Are you still having issues with this?

bwolven's avatar bwolven (2020-06-19 10:57:28 -0500) edit

Sorry, I was on vacation. Can you confirm that SetLocation=1 should be working for both Tuolumne and Alliance MLS? I will do some testing today and see if I can get those to import.

dhasler's avatar dhasler (2020-06-23 10:24:37 -0500) edit

Location=1 works on all Paragon RETS sites.
The only thing to watch out for is the URL may be returned as Protocol Relative like the one shown above.
So if it starts with "//" you can add either "HTTP:" or "HTTPS:" to it depending on your particular needs.

bwolven's avatar bwolven (2020-06-23 10:54:05 -0500) edit

Ah, that may be what's tripping us up. Let me do some testing and verify that's the issue.

dhasler's avatar dhasler (2020-06-23 12:24:34 -0500) edit

That looks to be the issue. I've updated all of our Paragon feeds to utilize SetLocation=1, added logic for the Protocol Relative URLs, and will monitor their run times.

dhasler's avatar dhasler (2020-06-23 12:42:47 -0500) edit
add a comment see more comments

1 Answer


Protocol Relative URLs were not being read correctly. Adding HTTP: resolves successfully.

dhasler's avatar
answered 2020-06-23 12:43:30 -0500
edit flag offensive 0 remove flag delete link


add a comment see more comments

Your Answer

Login/Signup to Answer