Ask Your Question

Revision history [back]

SJSR-Retrieve Image Data

Good Afternoon,

I've been trying to access image data for SJSR IDX feed for the last few days and am hoping someone can show me the error of my ways.

I tried to access it through the Media resource first and was greeted by the SystemNames, but all the data was NULL and at the end of the file it said

["restricted_indicator":protected]=> string(4) "**" ["maxrows_reached":protected]=> bool(false)

I then tried this query

$search = $rets->Search($resource, $class, $query, array('RestrictedIndicator' => 'RESTRICTED') );

and was returned with

["restricted_indicator":protected]=> string(10) "RESTRICTED" ["maxrows_reached":protected]=> bool(false)

Figured I'll try a few more methods, onto getobject! I tried a simple getobject

$objects = $rets->GetObject("Media", "RE_1", "547088", "*", 1); var_dump($objects);

Everything in the value said protected and at the end of the result it read "Invalid Type [RE_1]"

I tried the url getObject next https://sjsr-rets.paragonrels.com/rets/fnisrets.aspx/SJSR/getObject?Resource=Media&Type=RE_1&Id=547088:0&rets-version=rets/1.8

I was kindly returned with another RETS ReplyCode="20401" ReplyText="Invalid Type [RE_1]. "

I double checked the class through RETSMD.com and confirmed the class is RE_1 and RE_1 is the same for the property resource and that works fine!

I then tried to access the data from the URL, found all the metadata and searched with this query https://sjsr-rets.paragonrels.com/rets/fnisrets.aspx/SJSR/Search?SearchType=Media&Class=RE_1&QueryType=DMQL2&Query=%28L_Status=%7C1_0%29&Count=1&Format=COMPACT&StandardNames=0&Limit=50&rets-version=rets/1.8

I was once again returned with all the names of the columns but at the end was again greeted with RETS-STATUS ReplyCode="20201" ReplyText="No Records Found."

Just to be sure I wasn't losing my mind, I replaced "SearchType=Media" with "SearchType=Property" and I DID get data from that query, for some reason I simply can't access the urls of the images and I'm hoping someone can help me find my small, yet annoying error that I simply can't see.

Thanks for your time!

SJSR-Retrieve Image Data

Good Afternoon,

I've been trying to access image data for SJSR IDX feed for the last few days and am hoping someone can show me the error of my ways.

I tried to access it through the Media resource first and was greeted by the SystemNames, but all the data was NULL and at the end of the file it said

["restricted_indicator":protected]=> string(4) "**" ["maxrows_reached":protected]=> bool(false)

I then tried this query

$search = $rets->Search($resource, $class, $query, array('RestrictedIndicator' => 'RESTRICTED') );

and was returned with

["restricted_indicator":protected]=> string(10) "RESTRICTED" ["maxrows_reached":protected]=> bool(false)

Figured I'll try a few more methods, onto getobject! I tried a simple getobject

$objects = $rets->GetObject("Media", "RE_1", "547088", "*", 1); var_dump($objects);

Everything in the value said protected and at the end of the result it read "Invalid Type [RE_1]"

I tried the url getObject next https://sjsr-rets.paragonrels.com/rets/fnisrets.aspx/SJSR/getObject?Resource=Media&Type=RE_1&Id=547088:0&rets-version=rets/1.8

I was kindly returned with another RETS ReplyCode="20401" ReplyText="Invalid Type [RE_1]. "

I double checked the class through RETSMD.com and confirmed the class is RE_1 and RE_1 is the same for the property resource and that works fine!

I then tried to access the data from the URL, found all the metadata and searched with this query https://sjsr-rets.paragonrels.com/rets/fnisrets.aspx/SJSR/Search?SearchType=Media&Class=RE_1&QueryType=DMQL2&Query=%28L_Status=%7C1_0%29&Count=1&Format=COMPACT&StandardNames=0&Limit=50&rets-version=rets/1.8

I was once again returned with all the names of the columns but at the end was again greeted with RETS-STATUS ReplyCode="20201" ReplyText="No Records Found."

Just to be sure I wasn't losing my mind, I replaced "SearchType=Media" with "SearchType=Property" and I DID get data from that query, for some reason I simply can't access the urls of the images and I'm hoping someone can help me find my small, yet annoying error that I simply can't see.

Thanks for your time!

EDIT: After a few more hours of debugging and looking at the raw data, I'm convinced I don't have permission to view the RE_1 class in the Media Resource, I've successfully retrieved image data from the 5 other Media Classes. If you are part of the SJSR MLS and are able to access the RE_1 class of the Media Resource, please let me know.